TekRADIUS 內建 DHCP 伺服器的 Windows RADIUS 伺服器,支持 Microsoft Windows Vista, Windows 7-11 and Windows 2008-2022 server。
System Requirements
1. A Windows system with 4 GB of RAM.
2. Microsoft.NET Framework 4.8 (Min.)
3. 10 MB of disk space.
4. Administrative privileges.
TekRADIUS SQL (SQL Server Edition) 版 requires Microsoft SQL Server. Any version of Microsoft SQL server, including Express editions, may be used. The disk space required and SQL edition necessary depends on the application. Please see section entitled ‘SQL Server Configuration’ for instructions on how to configure the SQL Server foruse with TekRADIUS.
Although an “sa” equivalent SQL user is needed to create the initial database and tables, a less privileged SQL user may be used for regular operations.
TekRADIUS LT (SQLite Edition) 版 does not require an additional database server. TekRADIUS LT uses its own built-in SQLite database. TekRADIUS LT Manager creates database at first run automatically.
An SC/PC compatible smart card reader is required for importing SIM triplets from a SIM card.
Supported Standards
RFC 2131 Dynamic Host Configuration Protocol
RFC 2246 The TLS Protocol Version 1.0
RFC 2284 PPP Extensible Authentication Protocol (EAP)
RFC 2433 Microsoft PPP CHAP Extensions
RFC 2548 Microsoft Vendor-specific RADIUS Attributes
RFC 2607 Proxy Chaining and Policy Implementation in Roaming
RFC 2617 HTTP Authentication: Basic and Digest Access Authentication
RFC 2622 PPP EAP TLS Authentication Protocol
RFC 2809 Implementation of L2TP Compulsory Tunneling via RADIUS
RFC 2865 RADIUS Authentication
RFC 2866 RADIUS Accounting
RFC 2867 RADIUS Accounting Modifications for Tunnel Protocol Support
RFC 2868 RADIUS Attributes for Tunnel Protocol Support
RFC 2869 RADIUS Extensions
RFC 3079 Deriving Keys for use with Microsoft Point-to-Point Encryption
(MPPE)
RFC 3162 RADIUS and IPv6
RFC 3575 IANA Considerations for RADIUS
RFC 3579 RADIUS (Remote Authentication Dial In User Service) Support for
Extensible Authentication Protocol (EAP)
RFC 3580 IEEE 802.1X Remote Authentication Dial In User Service (RADIUS) Usage Guidelines
RFC 3748 Extensible Authentication Protocol
RFC 4284 Identity Selection Hints for the Extensible Authentication Protocol
RFC 4346 The TLS Protocol Version 1.1
RFC 4603 Additional Values for the NAS-Port-Type Attribute
RFC 4818 RADIUS Delegated-IPv6-Prefix Attribute
RFC 5281 EAP-TTLSv0
RFC 5246 The TLS Protocol Version 1.2
RFC 5997 Use of Status-Server Packets in RADIUS Protocol
RFC 6613 RADIUS over TCP
RFC 6614 Transport Layer Security (TLS) Encryption for RADIUS
RFC 6911 RADIUS Attributes for IPv6 Access Networks
draft-kamath-pppext-eap-mschapv2-02.txt Microsoft EAP CHAP Extensions
draft-kamath-pppext-peapv0-00.txt Microsoft PEAP version 0 (As implemented in Windows XP SP1’)
RFC 8446 The Transport Layer Security (TLS) Protocol Version 1.3
RFC 9190 EAP-TLS 1.3